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OVERVIEW 

 
TIDE is one of The Western Design Center, Inc. (WDC) tools. Other software and 
hardware tools plug into TIDE to make development more efficient and 
enjoyable. WDCTools consist of WDC’s proprietary ANSI Standard C-Compiler, 
Assembler, Linker, Object Inspector, Librarian, Debugger, and Simulator.  In 
addition to WDC’s proprietary development tools, WDC has plugged in WDC 
partner tools for WDC development. Users of TIDE can purchase these same 
tools from WDC’s partners or plug in their own tools. WDC partner tools include 
UltraEdit text editor, Aldec design entry, and Lattice FPGA tools. TIDE reduces 
the effort in working with these commonly used design and verification tools for 
65xx based microcontrollers and microprocessors and calls them to generate a 
binary output.  The binary output file can be loaded into hardware by using the 
Debugger (WDCDB).  The binary can also be simulated and debugged by the 
Simulator or connected to hardware through a TIDE port.  The options panel 
provides for easy configuration of the WDCTools. 

 

 
 

GETTING STARTED 
 
Let’s get started using TIDE! Below is a quick look at TIDE and its features with a 
step-by-step procedure for creating a project.  TIDE interfaces to your project 
board through an embedded monitor in combination with a physical TIDE port 
present on all of WDC’s SXBs and PXBs. 
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New Project 

Figure 1 – A quick look at TIDE Features and Tool Bar Icons  
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PROJECT SETTINGS AND OPTIONS 

 
The figures below describe common project settings; these are accessed by the top 
menu “Project->Options…”, or by clicking Project Options> . 
 

Figure 2 – Project Path Options. 

 
 

1) Compiler and Assembler Paths should be set to either: “wdc02cc.exe” and 
“wdc02as.exe”; or “wdc816cc.exe” and “wdc816as.exe” – setting the target 
selection in the figure below to either 8-bit or 16-bit will automatically set these to 
the correct values. 

2) The Linker Path should be set to “C:\WDC\Tools\bin\WDCLN.exe” for the default 
install location. 

3) The Simulator Path should be set to “C:\WDC\Tools\bin\wdcdb.exe” for the 
default install location. 

4) The Include and Library Paths should be set to “C:\WDC\Tools\include” and 
“C:\WDC\Tools\lib” if the default libraries are used; otherwise set these paths to 
the custom user libraries desired. 

5) The Source Path should be set to the source file of the main or top level “.c” or 
“.asm” file in the user project.  Use the “…” button to the right to browse to the 
file. 

6) The Binary Output should be set to the same as the source file above, but 
change the “.c” or “.asm” filename extension to “.bin”. 
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Figure 3 – Target Options. 

 
1) Set the “Target” radio buttons to select the base size of the target core 

a. W65C02S  
b. W65C816S Core 
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Figure 4 – Compiler Options. 

 
1) If Standard and/or Math libraries are included (see Linker tab below), set the 

memory model to match the target hardware to determine library size to use. 
2) If target has Micronas Hardware Multiplier, the click the appropriate box. 
3) If Post Optimization is desired for C compiler output, then click on “Peephole 

Post Optimizer” box 
4) Click on “Generate Assembly” to Create final listing file 
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Figure 5 – Linker Options. 

 
1) Set the “Code Segment” box to the address (in HEX) of the start of the code only 

if no ORG or SECTION statement is in the source code, if the source code 
specifies the code address, then leave this blank. 

2) Set the “Data Segment” box to the address (in HEX) of the start of variable data.  
If the source code specifies this, then leave this blank. 

3) Set the “Constant Segment” box to the address (in HEX) of the start of constant 
data.  If the source code specifies this, then leave this blank. 

4) If debug libraries and linker debug options are desired to be included, then check 
the debug box. 

5) If the math libraries are needed, then check the “Link Math Libraries” box. 
6) If the functions in the standard libraries are needed, then check the “Link 

Standard Libraries” box. 
7) For most C applications, check the “Link Startup Object” box; and ensure that the 

startup.asm file is not included in the project if checked.  Otherwise make sure 
this box is not checked. (for example for Assembly source only projects this 
should not be checked) 

8) Set the “Output File Format” radio buttons to the format needed. 
a. Most popular are pure binary, extended Intel Hex, and Motorola S-28. 
b. To produce binary output that is compatible with TIDE for loading into the Target 

hardware for running and debug, the “Western Design Center Binary” option 
should be selected. 

c. The other output formats are for specialty applications and self-descriptive 
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PLUG-IN TOOLS OPTIONS 
 
The Plug-In Tools Options dialog allows you to customize the settings for the Plug-In 
Tools. The figures below describe common project settings; these are accessed by the 
top menu “Plug-In Tools->Options…”, or by clicking on  icon. 

Figure 6 – Application Paths Options. 

 
 
The Application Paths Options Tab contains the paths to the executable files for each of 
the plug-in tools.  The default paths are to the tools that are used in WDC’s design flow.  
Trial and/or full versions of these software tools are available directly from those 
vendors.  
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Figure 7 – Work Directories Options. 

 
The Work Directories Option Tab allows you to configure the working project directory 
for each of the Plug-In Tools.  This allows for flexibility when launching the tools and 
ease of starting up your project for that particular tool.  For the Debugger, Editor, and 
Logic Analyzer tools there are three options:  
 

1) Path Above – This sets the working directory to the path indicated in the dialog 
box.   

2) None – This sets the environment to have no working directory. 
3) Project – This sets the working directory to the same path as the TIDE Project 

Directory.   
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MENU COMMANDS AND DETAILS 
 
The following are descriptions of the top level menu commands: 
 

Figure 7 – File menu: 

 
 

• “File->New->Project” will create a new project with default settings (see 
page 6 for example of using New Project) and open the Project Window. 

• “File->Open Project” will load an existing project with files and settings. 
• “File->Save Project” will save any changes to the existing Project. 
•  “File->Exit” will exit the application. 

 

Figure 8 – View Menu: 

 
 
• “View->Project” will display the current Project window and File Tree. 
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Figure 9 – Project Menu: 

 
 

• “Project->Options” opens up the Option setting tabs that are described 
starting on page 7. 

• “Project->Add Files” adds a source file to the current project.  The path 
and name of the file will be added to the Project Window and to the .WDC 
Project File.   

• “Project->Remove Files” deletes a selected source file from the current 
project.  The path and name of the file will be removed from the Project 
Window and from the .WDC Project File.  NOTE: A source file must be 
selected in the Project Window before performing this operation 

• “Project->Compile/Assemble” compiles and/or assembles the C and 
Assembly source files (same operation as the  tool-bar button 
described on page 5). 

• “Project->Build/Link” Compiles, Assembles, and links the source files 
(same operation as the  tool-bar button described on page 5).  Note 
that this operation will perform all of the functionality as Compile/Assemble 
and also Links all of the object files. 
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Figure 10 – Project Window: 
The Project Window displays all of the files in your current project.  The purpose of the 
Project Window is to manage all of the files in your project that will be 
compiled/assembled and linked.  From the window you can manage the files in your 
project.  This is done by right clicking anywhere in the Project Window and selecting 
either “Add Files” or “Remove Files”.  Once all of your files are added to the project, 
these files can be compiled/assembled/linked when the appropriate command is called.   
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SIMULATOR 
 
The simulator can be selected as an option in TIDE to allow execution and debug 
features such as step into and step over lines of code, watching variables and 
the state of the microprocessor for testing and debugging applications that do not 
contain hardware.  For more information on The Western Design Center, Inc 
Simulator, see the document entitled “Software Development System 
Simulator/Debugger.” 
 
 

SUPPORTED SYMBOL FORMATS 
 

• 2500AD symbol file 
• MicroTek symbol file 
• Extended MicroTek symbols 
• Quick symbol file 
• Symbol file 
• text symbol file (.map) 

NEW PROJECT EXAMPLE 
Note: that TIDE will not create a new source file.  You must navigate to an existing file 
with .c, .asm, or .s extensions and select the existing files you want to add to the project. 
It is suggested to put each new project into its own folder. 
 

1) Select “File->New Project”> ( ).  Enter a project name and select OK. 
2) Select “Project->Options”> ( ).  Fill in the Path, Target, Compiler and Linker 

Tabs. 
3) Select “Project->Add Files” or right-click in the Project window and select “Add 

Files”.  Note that TIDE will not create a new file.  You must navigate to an 
existing file with .c, .asm or .s extensions and select Open. 

4) Select “File->Save Project”> ( ).  Since it is the first time saving, you will be 
asked for a Project Name and Directory Path.   

5) Click on “Project -> Build/Link”> ( ) to compile/assemble and link. 
6) To Debug your application, click on “Debugger > ( ) to launch the debugger.  

Make sure that the Linker options are set to have a WDC Binary file created if 
using WDCDB. 

7) Step by Step Instructional Video is available on the WDC Youtube Channel 
 
 
 
 
 
 
 
 

http://www.youtube.com/watch?v=bbfEleNRH1o
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W65C02S_ Demo PROJECT EXAMPLE 
The WDC_Tools installation comes with two Demo Projects.  One is using the W65C02S 
and the other is for W65C816S.  The projects are located in the C:\WDC\Tools\Projects 
folder.  The instructions below are for the W65C02S_Demo. 

1) Select “File->Open Project”> ( ).  Navigate to the 
“C:\WDC\Tools\Projects\W65C02S_Demo” Directory.  Make sure that the file 
type is set to “WDC” and select the W65C02S_Demo.wdc project file and click on 
the Open button. 

 
 

             
 
 

2) The Project Window will show you the path of the Assembly file that is attached 
to the project if you click the arrow next to assembly 

              
 

3) This project has already been assembled and linked.  However if you edit the file, 
you will need to Click on “Project -> Build/Link”> ( ) to assemble and link. 
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4) Now you are ready to launch the Simulator.  The project options are set for 

simulation.  To Debug your application, click on “Plug-In Tools Debugger” > 
( ) to launch the simulator/debugger.  The simulator will pop open with the linked 
code showing.   
 

              
 
 

5) In the above screenshot you will see that breakpoints have been placed in the 
project for you. To make adjustments to breakpoints use the Breakpoint 
dropdown menu.  

6) To choose run operations for project you can manually select Run dropdown. 
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